The WG resolved to go with a fourth option, and just use the name 'order'.
Should we rename the 'flex-order' property? It has nothing to do with flexing, and its functionality may be useful in other new layout specs, e.g. Grid's auto-layout algorithm.
As well, 'flex-order' might be a good name in the future for putting elements in “flex groups”, such that one group gets first crack at the free space ahead of other (in the old flexbox spec, this was called 'box-flex-group').
A. (current spec) Name it 'flex-order'.
B. Name it 'box-order'.
C. Name it 'display-order'.